More info on smbfs mounted file, tail -f still does not work

root root at
Sat Nov 18 03:35:04 GMT 2000

Some new info:

I decided to write my own "tail" program to open the stream and attempt to
continuously read characters.

Interesting result...  The stream actually does contain data, all hex 00.
Every now and then bits of actual data come through, and then back to all
00's again.

Still completely stuck on this one.



> I have tried the suggestions noted in prior appends, and it still does
> not work.
> I upgraded to kernel 2.2.18-21 as suggested.  This did not fix the
> problem.
> I then upgraded from samba 2.0.7-21 to 2.0.7-23.  This also did not help
> (I did not expect it to).
> My current system: Linux version 2.2.18pre21 (gcc version egcs-2.91.66
> 19990314/Linux (egcs-1.1.2 release))
> The basic problem:
> 1) start appending to a local NT file from a process running on the NT
> box (I used ping -t > temp.txt)
> 2) "mount -t smbfs" the NT share on the linux server.
> 3) try "tail -f temp.txt"
> Tail will list the contents of the file up to the "current" end of file,
> and then either first report "==> temp.txt: file truncated <=="
> or just "hang" as if no additional records were being appended to the
> file.  If you leave it running, OCCASIONALLY you will get a PARTIAL
> record displayed (at random intervals)
> The tail output follows:
> Reply from bytes=32 time<10ms TTL=128
> Reply from bytes=32 time<10ms TTL=128
> Reply from bytes=32 time<10ms TTL=128
> Reply from bytes=32 time<10ms TTL=128
> ==> temp.txt: file truncated <==
> .1: bytes=32 time<10ms TTL=128
> e<10ms TTL=128
> 0.0.1: bytes=32 time<10ms TTL=128
> This problem is not limited to "tail".  I have tried other applications =
> that also can not continuously read the file as they are supposed to be =
> able to (they work if the file is linux-local, though).  Also, if you =
> append to the NT file from the linux box then tail DOES see the change.  =
> Yet another also, if you break and then restart the appending process on =
> NT (keeping the linux tail running) then the NT box reports: "The =
> process cannot access the file because it is being used by another =
> process".  Seems like there is also a locking problem (I tried mounting =
> the filesystem "ro" but that did not help either).
> This is a real mess.  Any help would be greatly appreciated.
> Thanks,
> Jason

More information about the samba mailing list