Microsoft Project 2000

Cindy Hodgins Burian chodgins at
Tue Nov 7 17:22:39 GMT 2000

David Collier-Brown wrote:
> Cindy Hodgins Burian wrote:
> > We are running Samba 1.9.18p10 and the main box we push files to is an
> > NT Terminal Server 4.0.  Until Project 2000, we've had no problems.
> > This is what's happening now:  Joe creates and saves a project on an NFS
> > file system pushed by Samba.
>         Can you reproduce this on a test share NOT using
>         nfs? That would eliminate nfs problems from the
>         debugging... (step 1)

Unfortunately, no.  We only share nfs files.

>         Indeed, is the reproducible, or does it only happen
>         occasionally?

It happens every time without fail.

>                          Jane opens this project, makes changes,
> > tries to save it, and it refuses.  Gives a popup box saying basically
> > You don't have permission to save this file.  When you look at the file
> > permissions through Unix, everything looks fine.  Even if you do a chmod
> > 777, it still fails.
>         That's interesting: I assume you're doing so from the
>         command line on the server, so the result **should**
>         be a file which Samba can write.
>         However, Windows people often use a "rename" scheme
>         to keep around unchanged and backup copies of the
>         user's work (eminently reasonable: Windows dies a lot)
>         You may need to change the permissions of .bak or other
>         odd files.
>         Try setting force create mode as the second step, as
>         suggested in
>         Then see what files Project creates as the third, whether or
>         not the second yields any results.
> --dave

Here is a piece of my smb.conf:

        path = /home/eng/NT
        writeable = yes
        force group = research
        create mask = 775
        force create mode = 0660

I just added the force create mode and tried this scenario again.  Still
got the same result.  Any more ideas??


More information about the samba mailing list