Samba login

Lee Howard faxguy at
Thu Nov 2 16:58:46 GMT 2000

At 10:04 AM 11/2/00 +0100, =?iso-8859-2?B?TmFneSBUYW3hcw==?= wrote:
>    Hello,
>I've noticed that when the inner network is slightly loaded,  the computers
>farther on (the) linux, couldn't enter the network. It's  because (the) linux
>doesn't allow them to enter. (The) Windows messages that  the password isn't
>correct or there's no suitable domain controller. I'm sure  that the password
>is correct because several times I try to log in, (the)  linux allows me to
>enter, but once in a while it hasn't allowed me.
>In  that case when (the) linux didn't allow me to enter, in the log file I
>found  things like that:
>[2000/10/31 11:17:31, 0]  lib/util_sock.c:write_socket_data(537)
>  write_socket_data: write  failure. Error = Broken pipe
>[2000/10/31 11:17:31, 0]  lib/util_sock.c:write_socket(563)
>  write_socket: Error writing 4 bytes  to socket 11: ERRNO = Broken pipe
>[2000/10/31 11:17:31, 0]  lib/util_sock.c:send_smb(751)
>  Error writing 4 bytes to client. -1.  Exiting
>What to do?

In the period of a week now, I've seen at least four different people
report this exact problem (and I'm one of them!), and I respect that David
Collier-Brown yesterday posted a thorough message trying to explain the
problem, and how to diagnose it, but I don't buy that there is bad hardware
or network misconfigurations.  Everything else to do with networking is
going fine - no interrupts, no resets, no crashes, etc... and the network
load really isn't *that* heavy at all.

The last thing that I tried was to change the ethernet driver from the
3c59x to the 3c90x for the 3Com 3C905C ethernet cards that are in the
system (even though I have a number of other systems with these cards using
the 3c59x driver just fine with no errors).  That didn't help, either.

I've tried playing with 'socket options =' with no luck.  The default
'keepalive =' setting *is* 0, and the systems are not crashing, bombing,
rebooting, etc at the time of these errors, either.  But still, my other
Samba networks don't even report any errors when those systems *do* crash,
bomb, reboot, etc.

So, I honestly think that there is a bug somewhere in Samba.  I posted the
code to the list for the write_socket_data routine, cause I don't know C,
and nobody even mentioned it.

Anyway... I'm just trying to say that I think there is something going on
here, and I wish that someone would take notice.



More information about the samba mailing list