incomplete printing, CVS, smbmount

Bernardo M. Brummer bernardo at
Mon May 29 21:13:51 GMT 2000

System: FreeBSD 3-4 STABLE (Gateway PII 450):

1. Epson Stylus Color 800: prints OK when attached to Win98 paralel port,
prints well, small - medium jobs, with samba, but only  prints the begining of
bigger (graphics, etc) files. It just stops, keeps blinking green light and does
nothing (spooler looks empty) until reseted.

I tried raw printing (no filter), increasing shared memory but nothing helped.

Testparm and smbstatus output are:

# testparm | grep "print command"
        print command = lpr -r -P%p %s      
# testprns lp1
Looking for printer lp1 in printcap file /etc/printcap
Printer name lp1 is valid.  
# smbstatus
Samba version 2.0.2
Service      uid      gid      pid     machine
bernardo     bernardo wheel      702   une_bernardo ( Mon May 29 17:14:33 2000
No locked files
Share mode memory usage (bytes):
   5242768(99%) free + 56(0%) used + 56(0%) overhead = 5242880(100%) total    


2. I would like to upgrade to the latest stable samba (2.0.7 ?) through cvsup.
Is it possible ? Wich server and what commands should I use ?


3. I would like to mount Windows (NT and Win98) filesystems on my FreeBSD box.
I used rumba (quite a long time ago), worked very good, I hear smbmount does
the same. I know it runs in Linux, does it run under FreeBSD native or Linux
emulation mode ?. Any other alternative for this question ?

Bernardo M. Brummer		Tel: +55 61 321-3525
bernardo at		Fax: +55 61 225-9541

More information about the samba mailing list