NT SMB Support parameter questions

Mike Brodbelt m.brodbelt at acu.ac.uk
Wed May 3 12:02:24 GMT 2000


I've recently had the following experience, which may be of help to
people here, so I'm mentioning my tests and conclusions.

I've recently been observing this behaviour from Samba - this is an
easily reproducible problem:-

1/ Open a share
2/ Create a new document in Word.
3/ Make some changes.
4/ Save the document using the save icon on the toolbar, this works as
5/ Make some more changes.
6/ Click the application close icon on the Word window titlebar
7/ Word prompts to save changes.
8/ Answer yes, error is generated:-

"There has been a network or file permission error. The network
connection may be lost. (\\CASTOR\TEST\TEST.DOC)"

9/ Ok this dialog, and the "Save As" dialog appears. After this point,
using the save as function, or trying to close word and clicking OK to
save changes regenerates the error. It can be worked around by saving
the document to a new name, but that appears to be the only way.

After some experimentation, changing the value of the "nt smb support"
parameter seems to have cured this. However, I get a number of files
called Ne01: or similar created on my shares, for no obvious reason, and
I had heard that this was due to a bug, which could be worked around by
setting nt smb support to no, which was why I had it set that way.


Server - Linux 2.0.x with Samba 2.0.7 (though this problem was certainly
in 2.0.6) also.
Client - NT 4.0 with Service Pack 3

Can anyone tell me why this happens? The nt smb support parameter seems
to have strange and far reaching effects, but documentation concerning
it seems to be sparse to non-existent. I'm appending part of my
smb.conf. I also have a log showing what happens at step 8 above,
generated at
debug level 3, should anyone be interested, but it's too large for the


smb.conf excerpt
# Samba config file created using SWAT
# from localhost (
# Date: 2000/05/03 12:29:52

# Global parameters
        workgroup = MILKY-WAY
        server string = Castor Samba Server
        security = DOMAIN
        encrypt passwords = Yes
        password server = betelgeuse
        username map = /etc/smb.map
        debug level = 3
        log file = /var/log/samba/log.%m
        max log size = 50
        dns proxy = No
        hosts allow = 192.168.1. 127.
        printing = lprng

        comment = Test Share
        path = /usr/local/filestore/smb_test
        valid users = @everyone
        admin users = @smbadmin
        writeable = Yes
        create mask = 0755
        force create mode = 020
        directory mask = 02775
        force directory mode = 02070
        map system = Yes
        map hidden = Yes

More information about the samba mailing list