Non-root users cannot use smbpasswd

James Kreuziger jkreuzig at
Tue Mar 21 22:50:19 GMT 2000

I've searched the archives for an answer to this 
problem, and yet nothing that works seems to have 
been posted.  I've seen it posted many times
In my particular case, I'm running 
Samba 2.0.6 on Solaris 2.5.1, configured with the 
--with-smbwrapper, --with-automount, and 
--with-syslog options.  I also have samba set up 
as a PDC, and that seems to be working fine.  A 
stripped down version of my smb.conf file is included 

My client machines are W95 OSR2, and am using the 
encrypetd passwords.  I'm having the same problems 
that others are:  Ordinary users cannot change 
their smb passwords.  When trying to change the password 
through the control panel, it gives an "invalid 
password" message.  Fine, the user should just log 
into the unix server and use smbpasswd.  What follows 
is what echos to the screen:

% smbpasswd
added interface ip=<deleted> bcast=<deleted> nmask=
Old SMB password:
New SMB password:
Retype new SMB password:
machine rejected the password change: Error was : The specified
password is invalid.
Failed to change password for <user>

Here's what my log.smb says (log level = 2):

[2000/03/21 14:08:36, 2] smbd/server.c:main(735)
  Changed root to /
[2000/03/21 14:08:36, 2] lib/access.c:check_access(258)
  Allowed connection from localhost (
[2000/03/21 14:08:36, 2] smbd/reply.c:reply_special(97)
  netbios connect: name1=        name2=<Machine Name>        
[2000/03/21 14:08:37, 2] lib/access.c:check_access(258)
  Allowed connection from localhost (
[2000/03/21 14:08:37, 0] smbd/chgpasswd.c:check_oem_password(693)
  check_oem_password: incorrect password length (-814585590).
[2000/03/21 14:08:37, 2] smbd/server.c:exit_server(408)
  Closing connections

I've tried specifying the machine name with the -d option 
(a recomendation culled from the archives).  Doesn't work.  
I've tried having the user include their own name on 
the command line.  Doesn't work.  Sometimes, it will 
give me the above mentioned error, then if I try smbpasswd 
again, it tells me the password has been successfully 
changed after entering the "Old SMB password" (in which the 
user actually used their "New SMB password" as their 
"Old SMB password").  When the user tries to log in, 
neither password (old or new) allows then access.  
The only way that the users smb password can 
be changed is if root executes smbpasswd.

All complaints aside, I must be honest and say that 
samba has been one of the two most useful pieces of 
unix software I have ever used.  

If you have any questions, please feel free to contact 



Jim Kreuziger
UCI Autism Research Project
jkreuzig at

        workgroup = SIMPLE
        server string = Samba %v on (%L)
        security = user
        domain logons = yes
        encrypt passwords = Yes
        password level = 3
        log level = 2
        name resolve order = wins hosts lmhosts bcast
        deadtime = 30
        keepalive = 120
        client code page = 437
        os level = 35
        preferred master = Yes
        domain master = Yes
        wins support = Yes
        guest account = samba
        invalid users = root daemon bin sys lp smtp uucp nuucp listen dumper nobody

        comment = The domain logon service
        path = /projects/samba/logon
        public = no
        writeable = no
        browseable = no

        comment = New Users Test
        path = /projects/samba/users
        read only = No

        read only = No
        browseable = No

        comment = Guest share
        path = /projects/samba/guest
        read only = No
        guest ok = Yes

More information about the samba mailing list