`file exists', and messed up timestamps with NT4SP6

Juergen Lock nox at jelal.kn-bremen.de
Sat Mar 18 10:35:42 GMT 2000


 We've been using our new samba fileserver for a while now (its
running on FreeBSD), and found two problems.  First the one we
were already able to solve:  NT4SP6 machines copying files to the
server with e.g. the standard explorer resulted in the files ending
up with wrong timestamps (`now' instead of what was on the original
files).  After some archive searching i tried this in smb.conf and
it fixed it:

	nt smb support = no

 The other problem (which i only learned about a few days ago tho i
guess it must have been there from the beginning) is some graphics
programs getting a `file exists' error back (well, the german
equivalent) when trying to `save as' a new file on the server for
the first time, and it takes one or two more tries before it works.
(sorry for the vague description, this is what i heared from users,
still have to try to reproduce it myself.)  the fact that its graphics
programs makes me guess it could have something to do with the file
size, i.e. it only happens for `big' files?  the server has quotas
enabled but the fact that simply retrying always `fixes' the problem
suggests that they weren't exceeded.  And this has happened with both
win95/98 and NT.

 Btw is there some way to up the logging level for a specific
connection, or for all connections from a specific client machine?
If i have to debug this myself i'd like to do it without killing
all the other user's smb mounts...

 Oh and there was a third problem:  win95/98 got poor write
performance (NT didn't), had to tune the socket options to fix that.

 Thanx + Regards,
Juergen Lock <nox.foo at jelal.kn-bremen.de>
(remove dot foo from address to reply)

More information about the samba mailing list