RPC error, Samba2.0.5 and NT

fnumrich at USU.DE fnumrich at USU.DE
Wed Mar 8 10:24:05 GMT 2000


I've got the following problem:
I'm running Samba 2.0.5 on SUSE Linux 6.1 as fileserver in a network with 5
 clients with Win NT SP5.
It worked all fine untill I put one more share to my smb.conf.
Now I had 9 shares instead of 8. When I now tried to browse the shares from
 NT via the Explorer or
on the Shell via 'net view \\czwserv' I got a error telling me that a
RPC.method call failed.
(Something like: 'an rpc error occurred'' but in german while I use the
german NT).
After I reduced the shares again to 8 (doesn't matter which share I
removed) the problem went away.

I searched in comp.protocols.smb and found the following posting:
> I am running Samba 2.0.6 on Solaris 2.7 on 2 machines
> The 1st system works flawlessly, but the second one will
 >not allow me to connect to it from an NT Server.
 >Here is what I get when using "net view" on the NT system
 >c:\>net view \\snapper
 >System error 5 has occurred
 >Access Denied
 >Both systems have Identical smb.conf files except the shares
 >and the name of the system
 >Both systems have a smbpasswd file and is up to date.
 >Both systems can see each others shares when using the debug
 >techniques as described in the debug.txt files.

It seemd to be the same problem that I've got.
I've posted my 'workaround' (removing one share).
As response the following posting came along:

> > The reason I figured out was: My smb.config contains 9 shares.
 >> Removing one of them (no matter which one) solves the problem.
 >> Maybe its an NT-problem (somebody suprised?).
 >> Does anybody know more?
 >I had a similar problem with 2.0.6/win2k: "an rpc error occurred".
However I had 12 shares...
 >Deleting one, whichever, solved the problem.
 >I think this is a very weird thing.

Is this a known bug (either in Samba or in NT)?
Is there a better workaround than reducing the shares until it works?

Thanks. Frank

More information about the samba mailing list