Problems with password chat

William Kupersanin kuper at
Thu Jun 29 17:45:47 GMT 2000


I recently set up NIS on a Solaris 2.7 box that is running samba 2.0.7
as a primary domain controller. NIS broke password changing from the
clients (NT). When I turned on debuging, I see ...

  Invoking '/usr/bin/passwd kuper' as password change program.
[2000/06/29 13:25:09, 100] smbd/chgpasswd.c:expect(229)
  expect: expected [New] received [New password: ]
[2000/06/29 13:25:11, 100] smbd/chgpasswd.c:expect(229)
  expect: expected [New] received []
[2000/06/29 13:25:11, 3] smbd/chgpasswd.c:talktochild(266)
  Response 1 incorrect
[2000/06/29 13:25:11, 3] smbd/chgpasswd.c:chat_with_program(310)
  Child failed to change password: kuper

My password string seems to be correct. It is 

passwd chat = "New password: " %n\n "Re-enter new password: " %n\n \
 "*NIS passwd/attributes changed*"

Which seems to be correct as I have unix password sync set and therefore
my password session as root goes like ..

[ROOT:infoserv:~] passwd kuper
New password: 
Re-enter new password: 
NIS passwd/attributes changed on

I've tried to play with the spacing. I've tried to add asterisks before
and after the strings. Nothing has worked and it seems from the
debugging info that maybe samba is reading from the pipe before the next
string is being sent.

Does anyone have any pointers that might help me solve this quandry?

-- Willie

William Kupersanin
ph (202) 872-3914
fx (202) 872-0878

More information about the samba mailing list