Windows fails to update samba

Rapper rapcurl at
Thu Jun 22 08:51:58 GMT 2000


Please point me to a FAQ if this is a common question.

I am running Redhat  2.2.13 and samba 2.0.5a with win98 clients.

My problem is that when a user changes thier initial passwords, they
are then unable to access thier home shares. These users do not have
any unix access so wont have access to change thier unix level passwds.

My current guesses are
1) Samba is failing to encode and store the password its given.
2) Windoze is forgetting to tell the network the password has been

Ive tried to debug the password chat by setting "passwd chat debug =
setting the log level to  110, adding a -l to smbd and nmbd command
and starting with an empty directory.

Then turn to my windoze machine and change the password.

Problem is that I cant find _*ANY*_ reference to changing the password
in any of the log files.

So I tried tcpdump on the connection. I can see the activity whenever I
view files or directories, but when I change the password, theres

The result is that windoze does change the passwd, but when it comes to
it, the validation fails cause smbpasswd is now out of date.

Any ideas?

More information about the samba mailing list