Andrew McRobert mcrobert at
Fri Jun 2 05:39:40 GMT 2000

hi all

I'm still having problems with user's being able to change their passwords
(either through telnet + smbpasswd or through the SWAT function). I'm
getting the classic "machine rejected the session setup. Error was
: ERRSRV - ERRbadpw (Bad password - name/password pair in a tree connect or
sesssion setup are invalid).

... the relevant entry in the smb log file is:

"[2000/06/02 13:30:44, 1] smbd/reply.c:reply_sesssetup_and_X(988)
  Username  is invalid on this system"

my "globals" section of the smb.conf file is:

# Global parameters
	workgroup = LAW
	netbios name = LAWPC34
	server string = Samba 2.0.7-2
	interfaces = eth0
	encrypt passwords = Yes
	local master = No
	wins server =
	guest account =
	admin users = mcrobert

I know it's pretty basic, but I've tried to start afresh to avoid the
password problems (ie. I've upgraded to ver 2.0.7-2 & completely new
smb.conf file). Is there a possibility the problem's caused by bad file
permissions/ownership on smb.conf or smbpasswd (more likely the latter)?
I've tried adding the following line to "interfaces":

	[server ip]/22,
... as opposed to 'eth0'. The /22 represents netmask of

any help/mindblowing solutions are welcome ....



Andrew McRobert LLB B.Sc(Comp. Sci)
IT Officer, School of Law
Ph: 9360 6479
Fax: 9310 6671
e-mail: mcrobert at

More information about the samba mailing list