MS DevStudio 6.0 and directory case problems.

Silver, Nathan nathan.silver at
Thu Jul 6 16:04:18 GMT 2000


Ordinarily, I would search the archives, but they seem to be
down at the moment. I am having some problems with Microsoft's
Visual C++ 6.0 with a Samba server running on an SGI IRIX

The problem: The UNIX directory structure on our IRIX machine
contains mixed case names. (say /usr/PROJECT/Build) I've noticed
that DevStudio changes the directory name to all lower case during
project creation. No amount of tweaking the smb.conf could get
around this so I decided to try putting the DevStudio project files
on our Novell server, but keep the source on IRIX. That seemed
to work until I tried accessing the files in the project. Alas,
DevStudio now decides to make all the directory names UPPER case!

My attempts at resolving the problem: As above, having the non-
essential files on Novell was unsuccessful. Placing a symlinks
to try to resolve the case issues (ie. /usr/project -> /usr/PROJECT,
/usr/PROJECT/build -> /usr/PROJECT/Build) This worked to a certain
extent except when I tried creating the project again. DevStudio
can create one of it's files, but refuses to create anymore
(it complains of permission problems which clearly isn't the case
since it just created a file!)

I've tried setting 'preserve case = true' with 'short preserve
case = true' along with 'case sensitive = true' and most combinations

My question: Has anybody had this problem? Can it be fixed? (aside
from fixing the DevStudio or Windows source tree ;-) Is there some
sort of workaround?

The pertinent details are as follows (I'm not posting my smb.conf
unless someone feels it's necessary):

Server -
SGI Onyx2 running IRIX 6.5.5
Samba 2.0.5a

Client -
Windows NT with Service Pack 5
Visual C++ 6.0 Pro

Many thanks in advance for any help,
Nathan Silver, Simulation Software Developer
Computing Devices Canada
Vetronics Systems - Advanced Land Fire Control System
nathan.silver at

More information about the samba mailing list