smbclient -p <port> worked in samba 1.19.18p10, not in samba 2.x

Pete Peterson petersonp at
Wed Jul 5 16:23:39 GMT 2000

It appears that "smbclient -p <portnumber>" doesn't work as advertised in
Samba 2.x?  On both Linux 6.2 and Solaris 2.6, independent of firewalls and
the like, it works with old Samba (e.g. 1.9.18p10) , but not with new Samba
(e.g. 2.0.7).  The new version seems to *IGNORE* the port specification and
attempt to connect to port 139.

Here's the result when I try to send a popup message to one of my machines
at home.  Note that MediaOne blocks the standard NETBIOS ports, so I've
chosen a couple other ports.  I send the message to port $LINPOP or $NTPOP
and my gateway redirects it to port 139 on my Linux machine or my NT
machine respectively.

Here are two tests from the same Solaris machine, first with the current
Samba and second with the 1.19.18p10 version.
seadog> echo 'some message to home machine' | /opt/samba/bin/smbclient -p $LINPOP -I -M petep
timeout connecting to
Connection to petep failed
Note that smbclient tried to connect to port 139, not port $LINPOP.

With the old Samba, it works as advertised in the man page:
seadog> echo 'other message to my home machine' | /usr/local/smbclient -p $LINPOP -I -M petep
Connected. Type your message, ending it with a Control-D
sent 34 bytes (status was 0-0)

Is this a bug in Samba, a bug in the man page, or some kind of
misunderstanding on my part?  The man page still proclaims the existence of
the "-p <port>" option.

        pete peterson
        GenRad, Inc.
        7 Technology Park Drive
        Westford, MA 01886-0033

        petersonp at or rep at
        +1-978-589-7478 (GenRad);  +1-978-256-5829 (Home: Chelmsford, MA)
        +1-978-589-2088 (Closest FAX); +1-978-589-7007 (Main GenRad FAX)

More information about the samba mailing list