Samba error when getting file from NT Server to Linux client

Paulo Henrique Baptista de Oliveira baptista at
Thu Jan 27 04:30:14 GMT 2000

        I have a small problem with Samba in Debian 2.1 (Slink), kernel 2.0.36
and samba 2.0.5. I have a NT Server and a Linux client.
        I want to get some files from NT Server to the Linux client.
        They are in the same network and the IP's are:
        NT Server -
        Linux Client -

        Reading samba docs I discover two small utilities: smbclient and
        Which is the best utility to do this?

        I have a username and a login in the NT Server:
        Login: Linux
        Password: AriaLinux
        The name machine is sideracop and the domain is sideraco.

        # smbmount //sideraco/c /mnt -U Linux -I -D sideraco -P

        and the following error occurs:

        smb_dont_catch_keepalive: server_data_ready==NULL
        mount error: invalid argument
        Please look at smbmount's manual page

        then I tried with smbclient:
        # smbclient //sideracop/c -M sideracop -I
        and it sends the message ok.

        but when I tried:

        # smbclient //sideracop/c -U Linux%AriaLinux -I
        SMBtconX failed ERRDOS -ERR nosuchshare (you specified an invalid
        Perhaps you are using the wrong sharename, username or password?
        Some servers insist that the that these be in uppercase.

        What is wrong?

Abraços,		PH
Paulo Henrique Baptista de Oliveira -- baptista at
Information Technology Consultant

More information about the samba mailing list