smbpasswd changes root password

Ramesh Babu ramesh at
Tue Jan 25 17:51:39 GMT 2000


This is a very scary problem I have here. I use a precompiled 2.0.6 samba
on my SGI IRIX 6.3 system. I also have smbpasswd file setup. When I tried
to change the samba password using smbpasswd program ( from a non root
account whic I use) I got an error messgae saying that it cannot change
the password. My goodness, I found that the instead of changing password
for my account smbpasswd changed the root account password. This
particular account has second group id "sys" and password program has both
suid and sgid bits turned on. I do not know if this is some bug in the
smbpasswd progarm or in my setting. I cannot imagine what would have
happend if some other user has tried to change his samba password. Can
anybody tell me what went wrong. Here is my smb.conf file. 

        workgroup = OCS 
        server string = SGI O2 At KNG's Lab
        update encrypted = Yes
        unix password sync = Yes
        max log size = 50
        max xmit = 8192
        shared mem size = 5242880
        os level = 0
        local master = No
        comment = Samba %v
        print command = /usr/samba/bin/sambalp %p %s %U %m
        hide dot files = No 
        comment = Your Home Ground
        read only = No
        browseable = No 
        comment = CD-ROM Drive on DNA
        path = /CDROM
        fake oplocks = Yes


Ramesh Babu
ramesh at
National Chemical Laboratory

More information about the samba mailing list