smbclient problems

Dunn, Dougie d.dunn at
Thu Jan 20 14:10:22 GMT 2000


I am having some problems retrieving files from a particular share on an
NT4.0 server using smbclient.  Other files from shares on the same server
transfer correctly.

I first noticed the problem when my AMANDA backups stopped backing up this
particular share just after xmas/new year.  Some investigation revealed the
problem was always with the same file/group of files.  There is no problem
accessing these files using Win95/NT clients, but all the same I ran
scandisk to check the filesystem.  No problems were reported.  Still cant
transfer these particular files.  Some sample output from amreport:
? added interface ip= bcast=
? code 0 opening remote file
? Error reading file \GEO\reports\cables\TAT14\FINAL\Segment-k\Smart
Report\Cables\OOSCAB_K.XLS : ERRDOS - ERRbadfid
? Didn't get entire file. size=51712, nread=0
? Error reading file \GEO\reports\cables\TAT14\FINAL\Segment-k\Smart
Report\chart-description\report.rtf. Got 0 bytes
? Didn't get entire file. size=135744, nread=51712
? Expected SMBtrans2 response, got command 0x2d

Next, I ran smbclient from the command line using the same parameters as
AMANDA would use.  Same problem, although it seems to be intermittent now,
i.e., sometimes the files will transfer correctly but seconds later they
wont.  I have checked the NT event log for anything which could be relevant
but nothing shows at all.

I can't think what to do next, has anyone seen this problem before and know
a fix?  I can provide some more verbose debug output if necessary, I didn't
want to output reams of info unless it was absolutely necessary.

Dougie Dunn
Seismic processing systems administrator
Fugro-Geoteam Limited

More information about the samba mailing list