Unsupported Printers - just "sticks" in the lpd queue ;(

Steve Frampton frampton at j-com.co.jp
Thu Jan 20 09:28:51 GMT 2000

Hash: SHA1


I've configured a Linux box with Samba to act as a secondary domain
controller for an existing NT server.  I've gotten everything working very
nicely, all my file shares set up, etc.

I've got 6 printers that I need to set up as print shares.  The ones that
speak Postscript or PCL were very easy to set up, and work admirably.  
However, I've got some WinPrinters as well as some unknown-format ones
which I would like to get working as well -- I realize I won't have the
luxury of being able to print from Linux on these, but surely I should be
able to set them up to simply pass, untouched, anything printed from a
Windows client (which would have the appropriate driver installed) to the

I have a Fuji Xerox Color Laser Wind 3310 -- it's Japanese, and an older
model, and no documentation could be found at fujixerox.co.jp on this
printer (however, with my level of Japanese proficiency, I'm rather glad
there *wasn't* any documentation available!)

I set it up in my /etc/printcap as follows:


When I try sending stuff to it, I just get the following (as reported
with 'lpc'):

          queuing is enabled
          printing is enabled
          1 entry in spool area
          sending to

I also tried getting rid of ":rp=raw:" and trying ":rp=:" instead.  
Nothing happens.

I did a portscan on the printer, and it only has ports 21 (FTP) and 515
(unknown) open -- the FTP server appears to be for updating firmware (my
guess), and port 515 immediately drops the connection if you telnet to it.
Therefore I have *no* idea how this printer is accepting data -- UDP?

I've checked the lpd man pages, the Printing-HOWTO (at
http://metalab.unc.edu/pub/Linux/docs/HOWTO/Printing-HOWTO) as well as
other web resources and have tried the various suggestions, but I'm
confounded as to why this isn't working.

I'm going to be working on other printers tomorrow including a miscreant
Fuji-Xerox Laser Press 4300, an Epson LP-8600F, and a Xerox Docu-Color
1250, all guaranteed to thoroughly test my patience.

So I'm hoping somebody will provide me a solution while I sleep
tonight.  ;-)

- --------------< LINUX: The choice of a GNU generation. >--------------
Steve Frampton    <frampton at j-com.co.jp>    Japan Communications, Inc.
Software Developer/Systems Administrator    http://www.j-com.co.jp/
GNU Privacy Guard ID: D055EBC5  (see http://www.gnupg.org for details)
GNU-PG Fingerprint: EEFB F03D 29B6 07E8 AF73  EF6A 9A72 F1F5 D055 EBC5
Version: GnuPG v1.0.0 (GNU/Linux)
Comment: For info see http://www.gnupg.org


More information about the samba mailing list