OpenBSD mac68k problems

Chester Jankowski jankowski at
Wed Jan 5 04:51:30 GMT 2000

I am trying to run Samba 2.0.6 on an OpenBSD 2.6 mac68k box and running into
problems. The clients I am using are NT4W SP6a, NT4S SP3 & SP6a, WIN 98, and
Redhat 6.1. I have tried various smb.conf files, but I don't think that is
the problem (testparm runs without complaints). I have completed all of
diagnosis.txt, and everything there works except for browsing shares in NT.
For the sake of simplicity, I am using the following .conf file for this

        workgroup = SAMBA
        encrypt passwords = Yes
        wins support = Yes
        log file = /usr/local/samba/var/log.%m
        load printers = no
        name resolve order = wins lmhosts host bcast

        comment = For testing only, please
        path = /home/test
        read only = No
        guest ok = Yes

1. For all the NT systems, I get similar errors. Using NT Explorer, I map a
drive (successfully)to the SAMBA share. At this point, in Event Viewer, I
get: Event ID: 3006 Source: Rdr, "The redirector received and SMB that was
too short." I can write to the share, but the SAMBA share will not accept
long file names. I think it's when trying to write to the share, e.g.
creating a folder and trying to make a long file name, that errors start
showing up in the log (I have a separate log for this client):

[2000/01/04 21:40:12, 0] lib/fault.c:fault_report(40)
[2000/01/04 21:40:12, 0] lib/fault.c:fault_report(41)
  INTERNAL ERROR: Signal 11 in pid 29513 (2.0.6)
  Please read the file BUGS.txt in the distribution
[2000/01/04 21:40:12, 0] lib/fault.c:fault_report(43)
[2000/01/04 21:40:12, 0] lib/util.c:smb_panic(2456)
  PANIC: internal error
[2000/01/04 21:40:12, 1] smbd/service.c:make_connection(535)
  cyberkrunk ( connect to service test as user chester (uid=1000,
gid=0) (pid 28455)
[2000/01/04 21:40:12, 0] smbd/dir.c:dptr_close(280)
  Invalid key 256 given to dptr_close

By now, I will have lots more Rdr errors in Event Viewer.

2. From the same NT station, "Net view" gives me an accurate listing of the
server and its server string. However, "New View \\quadra" gives me garbled
names for the shares, e.g.

Shared resources at \\quadra

Share name   Type         Used as  Comment

             IPC                   IIIIIIIIIIIIIIIIIIIIIIIIIIA


The command completed successfully.

The garbled names change every time I run the "Net view" command. Browsing
on Network Neighborhood gives similar results. I can see the icon for the
Samba server and its name and server string is correct. However, the shares
within are garbled.

3. With the Win98 client, I can map drives, browse and use long file names.
No errors show up in the machine's smb.log. However, when I look at the
share's properties in Explorer, they are garbled: label ttttt, File System

4. The Redhat 6.1 smbclient seems to run without errors.

In addition to compiling the 2.0.6 source, I have also tried the OpenBSD
2.0.5a port with similar results. Has anyone had success on this platform?
What should I try next?

Chester Jankowski
jankowski at

More information about the samba mailing list