Directory rename problem with smbclient

jpjanosi at jpjanosi at
Sat Jan 1 15:43:19 GMT 2000

After looking at the code from samba 1.9.18p10  I made the following change
to libsmb/clientgen.c to resolve this problem, is there any reason I
shouldn't do this?

*** clientgen.c.orig     Wed Nov 10 20:36:03 1999
--- clientgen.c     Sat Jan  1 09:28:32 2000
**** 1059,1065 ****

!          SSVAL(cli->outbuf,smb_vwv0,aSYSTEM | aHIDDEN);
           p = smb_buf(cli->outbuf);
           *p++ = 4;
--- 1059,1065 ----
!         SSVAL(cli->outbuf,smb_vwv0,aSYSTEM | aHIDDEN | aDIR);
          p = smb_buf(cli->outbuf);
          *p++ = 4;

---------------------- Forwarded by John P Janosik/Rochester/IBM on
01/01/2000 09:22 AM ---------------------------

I am trying to use smbclient to migrate data from OS/2 LanServers to a
filesystem on an AIX 4.3.1 machine.  Everything works great except renaming
directories on the OS/2 LanServer.  I get the error ERRDOS - ERRbadfile
(File not found.) renaming files when I do a "rename <existing_dir_name>
<new_dir_name>" at the prompt, but <existing_dir_name> exists.  I connected
to a NT Server and a Samba server with smbclient and am able to rename
directories on these systems.  I also tried connecting to the OS/2
LanServer from an NT client, and I am able to rename directories, so I do
not think there is a problem with the OS/2 machine.

Oh, I am using the smbclient from Samba 2.0.6, but I have also tried other
versions of smbclient back to 1.9.18 patch 3 with the same results.


John Janosik
IBM Global Services SDC North
Rochester Server Support, AFS/DFS Team
jpjanosi at

More information about the samba mailing list