Can't add new users/passwords in 2.0.3v Samba on Solaris 2.7

Jeanmarie Morel jmorel at
Thu Apr 20 18:46:19 GMT 2000

I downloaded and installed the binary 2.03 Solaris 2.7 version
of Samba three days ago from the Samba web page.  I installed as 
root on my SUN Ultra5 unix system.

I have accessed your configuration tool via http://<my unix ip>:901.
I logged in as root, and have been able to set up global items and

I cannot setup new users under the 'passwords' tab.  I enter
my user name, and password, and retype it in, and click on
the 'Add New User' button.  I get the following error.
	Netscape ERROR:
	The document contained no data.
	Try again later, or contact the server's administrator.

I have tried every day for three days.  Time to try something else.

I went into the /opt/samba/private' file and created a new
password entery in smbpasswd, as it said in the O'Reilly Samba 
book in section

I then went to run /opt/samba/bin/smbpasswd as the book suggested.

I got new errors:
[worf:/opt/samba/bin]13 # ./smbpasswd jmorel
New SMB password:
Retype new SMB password:
make_smb_from_nisp: NIS+ lookup failure: Error in accessing NIS+ cold start file... is NIS+ installed?
Failed to find entry for user jmorel.
Failed to change password entry for jmorel
[worf:/opt/samba/bin]14 # 

I then went in via the web, and tried again to create
a new user as root.  I still got empty doc error.
If I put in the username, and passwords, and select
the 'Change Password' button, I get the error:
	Failed to find entry for user jmorel.
	The passwd for 'jmorel' has NOT been changed.

I then went into the smbpasswd file and set the LAN Manager
Password Hash to begin with 'NO PASSWORD'.  I set the null passwords
option in Samba, and tried to connect from a Windows 95 PC.

I get the error on the PC of:
	Microsoft Networking
	The password is incorrect, try again.

I have tried with the all X password file too.  Same error.

I have shown the problem to someone who has installed Samba
here many time, and they did not know what was going on.
I, by the way, have no problem reaching those other Samba
servers from the same PC's I have failed with on to my Samba
server.  I have even cut and pasted the password listings from
those servers to mine, with the same errors as above.

I have checked your FAQ list, and don't see this problem
listed in there.

Anyone have any idea of what I can do next? 

Thanks for any constructive ideas.

- Jeanmarie

More information about the samba mailing list