MSAccess file locking problems on Linux

Wasson, Tim WassonT at
Mon Apr 17 13:17:11 GMT 2000

I'm running Slackware 7.0 (glibc finally!) with Samba 2.0.5a, and having
MSAccess97 (I know, doesn't scale, etc, but that's where we are) file and
disk errors when multiple people try to access the database (from Win NT
clients).  Simpler single-user file serving is working fine (excel, text
files, gifs), directory speeds are fine, copy speeds are fine.  This
database works fine when hosted on NT4.0 Workstation.  I've read something
in the archives about glibc Linux claiming to be 64 bit clean when it's not,
and then Linux has problems when Samba tries to use 64 bit locks, and that
this might be fixed in 2.0.6.  I've never tried this on a libc5 Linux box,
but I have one at home I can try this on.

I've even tried turning locking off completely, and op locking as well, but
doesn't seem to fix anything.

Should I try 2.0.6 or is this something that should work?

Tim Wasson

More information about the samba mailing list