9 shares give rpc error

Jeremy Allison jeremy at valinux.com
Tue Apr 4 20:16:12 GMT 2000

don_mccall at hp.com wrote:
> Hi Jeremy,
> I'll send you a smb.conf file that will allow you to reproduce; I
> reproduced on 2.0.6 and 2.0.7pre2....
> I ran a microsoft netmon trace on the shareenum, and I could SEE in the
> trace that the data was truncated, but that the buffertoolarge flag was
> not set and the additional parameters I expect in the smbresponse are
> not there. (ie, no error to let the client know to do an SMBREADX to get
> the rest of the info).  If I truncate one of the share comments by 10
> characters or so, or ADD a few characters, I can see that the additional
> parameters that the client is expecting are part of the 0x25 reply...
> (and I don't get the rpc error)
> I'll send the smb.conf file separately, let me know what you see.
> Thanks,
> Don

Did you try pre3 ? JF found a bug in this code that would
cause exactly the problem you describe with the DEC/RPC
enum - not the RAP one. I fixed it for pre3.

The offending line was in smbd/ipc.c :

It used to be (in 2.0.6 - 2.0.7pre2) :

    send_trans_reply(outbuf, NULL, 0, rdata, data_len, (int)prs_offset(&p->rdata) > data_len);

and is now (in pre3) :

    send_trans_reply(outbuf, NULL, 0, rdata, data_len, p->out_data.current_pdu_len > data_len); 

Which I think is exactly the fix needed.



Buying an operating system without source is like buying
a self-assembly Space Shuttle with no instructions.

More information about the samba mailing list