ACCESS mdb on Samba

Brendon Meyer Brendon_Meyer at
Tue Oct 19 01:02:36 GMT 1999

> Date:   Mon, 18 Oct 1999 08:16:08 +0800
> From:   "Ramon B. Nemo" <rbnemo at>
> To:     samba at
> Subject: ACCESS mdb on Samba
> Message-ID: <4825680E.0001FBCD.00 at>
> Mime-Version: 1.0
> Content-type: text/plain; charset=us-ascii
> Content-Disposition: inline
> hello there.  I posted a message like this last week.  I still got no answer
> though.  Am I alone in this samba community?
> Anyways, I have samba working on my openlinux 2.3.  I had it up and running
> (smbd /nmbd).  I successfully mapped the shared resource from a win95 box.  I
> started my vb program that gets data from an MS Access mdb file.  The program
> did went on adding new records, deleting and appending.  But when I connect
> through my other win95 box, I get this error;
> Cannot lock file, file is exclusively opened.
> So I turned off the first win95box and tried connecting again.  The same error
> occurred.  Tried adding max connection string to smb.conf, but to no avail.
> Why is this so?  Is it the Access database or my Samba?

Difficult to say, especially when you haven't specified your 'smb.conf' settings and have not specifically told us how you are opening the
'.mdb' file.

This is similar to a problem that I have run into here at PT Freeport with *many* Access clients (on 95 and NT) connecting to a single
'.mdb' file on a Samba 2.0.5a share, and this is how I have largely solved it for Access 95.  While it works for us I can't tell if it is
going to work for you as you are using OpenLinux 2.3 as apposed to FreeBSD 3.3 (which we use) so you mileage is probably going to vary.

Also, how well this works in Access 97/2000 I could not tell you - I just have not tried it.

Try including the following directives in your share that defines the area where your '.mdb' files are stored.

[<share name>]
        locking =               yes
        strict locking =        no
        fake oplocks =          no
        oplocks =               no
        level2 oplocks =    no
        share modes =           yes
        mangle locks =    yes
        dos filetimes =         true
        dos filetime resolution = true
        mangled names =         yes
        fake directory create times = true

Then ensure that the connecting users have the correct permissions (if Access can't write to the .ldb files then it isn't going to work

One final point to note.  You will note that I explicitly turn oplocks off.  From what I have read, theoretically they should work with
Access just fine but experience here has shown that to be not always the case so I turn oplocks off (which also means that level2 oplocks
directive is also pretty much redundant).  I am still interested in ideas and theories on why this is the case so if you get it working
with oplocks, I am interested in how you achieved this.

Anyway ... try these directives (if you aren't using them already) and let me know how it goes.

Brendon Meyer
(Brendon_Meyer at
PT Mineserve International / PT Freeport Indonesia / Freeport McMoran
Timika, Tembagapura, Jakarta, Singapore, Cairns, New Orleans

More information about the samba mailing list