Root did not create the semaphore

privledged SYSTEM account John.Lathouwers at
Wed Oct 13 04:35:09 GMT 1999

Hello all,
I have a very annoying situation (at least at my end).  I set up Samba
2.0.5 on a Digital UNIX 4.0F system sitting on a Compaq DS20 server with
great success.... until recently.  I set up three directory file shares
with no problems, when I tried to set up a forth, quite a while after
setting up the inital three, I tried to access it from a NT box, I got
the message server not found, but the other three were still
accessible.  Before rolling the server into production, I applied the
latest patches, did some virtual memory tuning and rebooted.  When the
system came up, I started the Samba Server and gave the thumbs up.  The
next day, I was confronted with users not being able to access ANY of
the shares.  I checked to see if the processes were running, and they
were,  then I ran smbstatus and recieved the messages:

ERROR:Root did not create the semaphore
ERROR:Failed to initialize share modes
Can't initialize shared memory - exiting

So I did some more kernel tuning, and even reverted back to the settings
when samba did work with no luck.  Although I can see smbd and nmbd
running in my process lists, SWAT only shows that nmbd is running.

Any help?  The best guess I have is that my kernel's shared memory and
semaphore settings are not high enough, although I did try to double all
the values with no success.

Thank You.

More information about the samba mailing list