PANIC: failed to set gid

InfraRED/Veres Tibor infrared at
Sat Nov 27 17:12:51 GMT 1999

hi, my samba setup worked virtually unchanged for nearly a year, but
yesterday the following errors appeared:

[1999/11/27 17:18:06, 3] smbd/process.c:switch_message(448)
  switch message SMBtconX (pid 7568)
[1999/11/27 17:18:06, 4] smbd/reply.c:reply_tcon_and_X(312)
  Got device type ?????
[1999/11/27 17:18:06, 3] smbd/password.c:authorise_login(727)
  ACCEPTED: validated uid ok as non-guest
[1999/11/27 17:18:06, 3] smbd/service.c:make_connection(426)
  Connect path is /tmp
[1999/11/27 17:18:06, 0] lib/util_sec.c:assert_gid(70)
  Failed to set gid privileges to (-1,1003) now set to (0,0) uid=(0,0)
[1999/11/27 17:18:06, 0] lib/util.c:smb_panic(2456)
  PANIC: failed to set gid

do you have any idea what can be the problem??

the system now runs debian potato, the samba package was recently
upgraded, but the problem persist if I downgrade the packege to a version
which worked a day before.. 

InfraRED of aurora-borealis/Veres Tibor <infrared at>

More information about the samba mailing list