Please Send Your Spam To This Address spam at
Sun May 16 18:48:32 GMT 1999

On Mon, 15 Feb 1999 23:47:50 -0500, Guy Dallaire wrote:
>When I try to access a file or a subdirectory under the share, I get a message telling me "File not found",
>or "this folder does not exist". 
>I tried all sorts of upper/lower, preserve, case combinations in smb.conf, nothing seems to work. I tried
>with debug level = 3 and I noticed a lot of "Error file not found, line=..." in the samba log. 
>If I use "make new folder" from Windows explorer, it creates a "New folder" directory but I cannot
>access it ! It say "the directory does not exist" 

I've just compiled and installed Samba 2.0.3 on NetBSD 1.4, but the
problems I'm seeing apply to previous versions and all platforms.  In
checking the configuration, I've discovered that the setting:

   case sensitive = yes

does not work with Windows 95; W95 will be able to list the files
located in the root share directory, but it cannot stat any of them, and
it can't see the contents of any subdirectory -unless- the filename is
in 8+3 uppercase format on the unix box.  (I also noticed a warning when
I tried to create a "New Folder" -- W95 told me that the directory may
not be usable!)  Changing this option to

   case sensitive = no

(and then sending SIGHUP to nmbd and smbd -- very important) allows W95
to see the contents of all directories and files as it should, with one
very annoying exception: files which are spelled the same but have
differing case.

> ...
>a) Can samba + win 95 be configured in such a way that if files AAA.dat, AaA.dat, aaa.dat exist under
>UNIX, I will be able to distinguish between the three files under win 95 ? 

I've noticed that if one of the files or directories has an
all-uppercase name, Samba will return its contents instead of one of the
others no matter which file was selected from W95.  The only
configuration option I see which applies here (other than case
sensitive, which doesn't work if set) is

   mangle case = xxx

which appears to have no effect whatsoever.

I'm seeing another problem, which I have no idea whether it's related to
name mangling: when I try to open the Properties of a file on a Samba
share, W95 will hang for a minute or more.  Sometimes I can regain
control by killing the smbd subprocess on the unix box.
Trevin Beattie
*** Due to the large volume of SPAM I am receiving,
    my email address will no longer be posted publicly in any form.
    Send replies via

More information about the samba mailing list