Network is busy...

Paul Sergeant pfs at
Wed May 12 16:32:14 GMT 1999

i do not have a direct answer but we had the following problem and fixed it.

	1. NO NT , the site was a SCO 5.0.2 and Red Hat 5.2 (kernel 2.2.4)
	   used a small win95 bos as a windows file server upto 10 user
	   no problem.

	2. Site increased pc count to 20 , needed to find a better file server.
	   could of used sco vision but what for samba 2.0.3.

	3. installed 2.0.3 on redhat (no recompile)

      4. worked out of the box, setup shares etc (no printing).

	5. after two weeks , installed Anti-virsus software on all pc's

	6. suddenly MAJOR problems with performance. upto 5 minutes for
	   word to open a doc. 10 minutes for explorer just to open a

	7. Turn off the auto-protect deamon and performance return nearly
	   back to normal, every so often a user would say their system
	   was very slow (5 mins. word/excel etc..)

	8. looked at log and fine oplock break ou/reset errors whenever
 	   the user said the problem occurred and on the file they where
	   tring to access.

	9. disabled oplocks and did some of the performance tricks already
	   posted to this list in the last month or two. restart samba each
	   night after full backup.

	10. performance has been fine ever since.

	11. the redhat box has a 3com, the win95 boxes have intel/kingston or
	    dec cards.
	12. only time we get a lot of collisions on the hub is when we run virus
	    check across all shares (once a week , about 2GB data , takes 10
	    performance dips a little(ie:person open a word doc from explorer.
	    closed doc , returns to explorer and for 2 seconds can still see the
          ~edited version of the doc) normally a reboot of redhat sorts this

	Hope this helps someone.

	paul sergeant
	it manager

-----Original Message-----
From: samba at [mailto:samba at]On Behalf Of W. Bryan
Sent: 12 May 1999 17:01
To: Multiple recipients of list
Subject: Network is busy...

I have done a great deal of reading regarding the network is busy error,
but haven't come up with an answer for one particular problem.  Here is the
situation.  Two identical DGUX machines are sitting on a network.  Both
machines are running Samba 1.9.10 with no problems other than performance.
Upon several recommendations about improving performance, they decided to
upgrade to 2.0.3.  Downloaded source and compiled it on their test machine.
 Worked flawlessly, and it helped the performance problem they were having,
so they decided to put it on their production system.  The copied the
binaries from the test system to the production system, and when trying to
connect from various windows 95 machines, they always get the network is
busy (error 54) message when trying a net use command or clicking on the
machine in network neighborhood.  They tried compiling the samba 2.0.3
directly on the production server, still had the same problem.  They then
reinstalled the old 1.9.10 version and it started working correctly again.
They can connect to the production machine running 2.0.3 from both NT and
other unix machines using smbclient, just not windows 95.  The windows NT
does, however, have a long delay when making the initial connection.
Neither machine is running bind, they simply have host tables.  We have
tested gethostbyaddr to make sure its not stalling out, and it returns
instantly with either a host name from the host table, or an error if the
name is not in the host table.  We have tried having a host table entry for
the win95 machine, and not having a host table entry, and it makes no
difference.  The test system does NOT have host table entries for the win95
machines, and it works correctly.  Both the test and production servers are
connected to the same fast ethernet switch, all other IP  connectivity is
fine between clients and the production server.  We have made sure that
there are no other processes running that should conflict with samba.
Also, they are using guest accounts, with security=share, no passwords at
all so there shouldn't be any goofy password or encryption issues here.
The smb.conf files are identical in the global section between the 2
servers, only the shares themselves are different.  The smb.conf file is
very plain, no socket options, no NT domain stuff, no security, nothing.
Only the workgroup name and dns proxy=no are in the global section.  This
has become a pretty serious issue, and we obviously need some additional
help, because we are rapidly running out of ideas.  Please let me know if
you have any thoughts of what we might be overlooking.  Thank you in
W. Bryan Caudle
Commonwealth Technical Services, Inc.
Voice: 804-639-5400    Fax: 804-739-7007

More information about the samba mailing list