Performance (?) problem with Samba and NT

Brian Ginter brg at
Mon May 10 21:20:04 GMT 1999

> Date: Mon, 10 May 1999 09:24:38 -0400
> From: "Hall, Ken (ECCS)" <KeHall at>
> To: Multiple recipients of list <samba at>
> Subject: Performance (?) problem with Samba and NT
> Message-ID: <59523CAF2AA3D111A8AB00805FE67F2E6F3BBA at>
> I've seen this question asked on the list, but never answered.  I've tried
> searching the archives, etc., but don't find anything relevant.
> I have a network with several Win95 and 98 client machines and one NT4
> machine (NT Workstation, not Server).  It's currently using Novell, but I've
> been testing a Samba server as a replacement.  The 95 and 98 clients work
> fine.  When I browse the network, the server appears, I can open it, look at
> the shares, etc.  Everything is quick and correct.  Even printing works
> fine.
> On the NT machine, however, it takes up to a minute to open the Samba Server
> in Network Neighborhood.  It takes up to another minute to open any of the
> shares.  If I run "NET USE" from a command-line window, it takes the same
> amount of time to complete.  Once the share is mapped to a drive, it works
> fine for a while, but after a time, you can't open "My Computer" without
> another long wait, and can't access the mapped drives without another long
> wait.
> This is Samba 2.0.3 on RedHat 5.2, but I'm having a similar problem on a
> test box running 5.1 and an older version of Samba.  The NT system was at
> SP3, and is now at SP4.  The upgrade had no effect on the operation.
> Defining a WINS server on the NT system had no effect, other than to make
> the "Workstation" service fail to start most of the time.  I'm using
> SECURITY=USER, and everything else seems to be working fine.
> I had tested this setup with NT Server a while back, and I vaguely recall
> having similar problems with it, but I gave up on it for other reasons
> before I had a chance to figure out what was wrong.  Because of this, I
> suspect the problem is on the client side.
> Anyone have any ideas?

Do you have Novell Client 32 installed on the NT machine?  I have 
this problem on my NT machine which does use Client 32.  Several 
other NT boxes with MS client work just fine.

More information about the samba mailing list