Samba 2.0.x unusable for this environment

Jay Anderson Jay.Anderson at
Mon Jun 21 20:52:34 GMT 1999

I just attempted to upgrade from Samba 1.9.18p10 to Samba 2.0.4b, and I
have had to revert to 1.9.18p10 in less than a day.  I attempted to
upgrade to 2.0.1 back in January, and had to back off as well.  I was
hoping the problems I saw then would be resolved in 2.0.4b.  I sent a
message to this list back in January or February as well, but saw no

My environment is about 210 Win95 PCs (with a few NT 4.0 workstations
thrown in) and 6 MetaFrame servers (SP4).  I compiled Samba on Solaris
2.6 using gcc 2.8.1, and I am running it on a Sun Ultra-1 with Solaris
2.6.  The network connection is 100BaseTX.  The Samba server is acting
only as a conduit, there are no local data filesystems; all shared
directories are NFS mounted filesystems.  The problems and symptoms that
caused me to back off the new version of Samba were:

- occasional error on saving file to Samba share resulting in corruption
(mainly from PCs)
- printing problems; no output, or corrupt print jobs hanging printers
- each MetaFrame server would have only a single smbd process, instead
of a separate smbd process for every user, as with Samba 1.9.18p10

I ran Samba 2.0.3 and 2.0.4 and 2.0.4b on a test server with up to four
users with no problems.

I use "security = user" for Samba 1.9.18p10.  Last January I tried
running with "security = domain," but this time I thought I'd try
changing one thing at a time, so I ran with "security = user."

I am attaching the global section and representative shares from my
smb.conf.  Sure would appreciate some ideas on what is going wrong.
Samba 2.0 is unusable for me until I can resolve these issues.

   security = user
   printing = sysv
   guest account = nobody
   status = yes
   encrypt passwords = yes
   printer driver file = /usr/local/samba/lib/printers.def
   lock directory = /usr/local/samba/var/locks
   share modes = yes
   dead time = 15
   socket options = TCP_NODELAY
   lpq command = /usr/bin/lpstat -o%p -L
   lprm command = /usr/bin/cancel %p-%j
   print command = /usr/bin/lp -c -d%p %s ; /bin/rm -f %s
   max log size = 1000
   interfaces =
   workgroup = JDDW-
   local master = no
   domain master = no
   wins support = no
   wins server =
   wins proxy = yes
   dns proxy = no
   domain logons = no
   logon drive = h:
   preserve case = yes
   short preserve case = yes
   case sensitive = no
   server string = Davenport Works - Samba %v
   remote browse sync =
   remote announce =
   message command = csh -c '/usr/bin/mailx -s Winpopup postmaster <
-f %s' &
   map to guest = Bad User

   comment = Home Directories
   browseable = no
   writable = yes
   create mode = 0775
   directory mode = 0775

   comment = Forms
   path = /share/forms
   public = no
   writable = yes
   printable = no
   create mask = 0775
   directory mask = 0775

   comment = QMS410
   path = /var/spool/samba
   browseable = yes
   printable = yes
   public = yes
   writable = no
   create mode = 0700
   printer driver = QMS-PS 410
   printer driver location = \\%L\PRINTER$

Jay D. Anderson                         John Deere Davenport Works
Jay at                           P.O. Box 4198
Phone: 319.388.4268 Fax: 319.388.4159   Davenport, Iowa 52808

More information about the samba mailing list