Horrible smbmount problem

Stephen L Arnold arnold.steve at ensco.com
Tue Jul 20 20:18:33 GMT 1999

When the world was young, Jonathan Kelly <j.kelly at julien.ca> carved 
some runes like this:  

> I have a problem with smbmount between two Linux (both: RH 6.0,
> kernel 2.2.9, samba 2.0.4c) boxes. When I use smbmount, the
> share loads and I can read files just fine, but when I copy ("cp
> file") to the share, the first 512 bytes of the file are copied
> and then the copy just freezes there. Trying several times to
> kill -9 the process didn't work. I had to reboot the server. Now
> I tried both the smbmount included in samba 2.0.5-pre3 and in
> smbfs-2.0.4b-19990519.i386.rpm on the samba ftp site. Both had
> the same effect. 

The only time I've seen a hard lockup like this (with linux, samba, 
netware, windoze, whatever) was due to a bad NIC.  Oh, it looked 
like it worked, most of the time (with a DOS/Win Netware Client 
setup), but with linux running the ncpfs client I could make it 
barf repeatedly just by copying a file larger than 16 megs.  When I 
replaced the NIC with an SMC 8*13 card, the problems disappeared.

What happens when you move some data using ftp, nfs, etc?  If it's 
not bad hardware, then something is hosed in your samba/smbfs setup.

I haven't used RH6 or samba 2.x yet, but I've seen a few glitches 
mentioned on the list (eg, the 64-bit file locking glitch on linux-
intel).  Have you tried samba 1.9.18?

Sorry I couldn't help more, Steve

Stephen L Arnold                      http://www.rain.org/~sarnold
#include <std_disclaimer.h>

More information about the samba mailing list