Help! NT not sending file to printer?

Alain M. Gaudrault alain at
Thu Jan 28 18:56:44 GMT 1999

"Oleg Kustov" <O.Kustov at> wrote:

>>I have Samba set up properly enough so that I can see both disk and
>>printer shares from Network Neighbourhood, I can mount the disk shares
>>and use them, no problem.  I can even Add a Printer without any
>>hiccups.  But when I try to print the test page, NT pops up "Test page
>>failed to print.  Would you like to view the print trouble shooter for
>>assistance?  The parameter is incorrect."  Attempts to print from any
>>programmes fail as well.

>I had the same problem. I solve it by adding line as above in
>my smb.conf.   My UNIX is Linux that do not let print with
>username "nobody".

Tried it, didn't work.  But even if it had worked, I don't want just
anybody to be able to print, only those with permission, just like the
drive shares (every user account is mirrored on both the Linux and NT
boxes).  And like I said, everything works well with the drive shares,
it's just the printer shares.  And the system level trace seems to show
that no data is being sent from NT to the Samba server.

I'm really at a loss here, as I've gone through all the docs, have tried
all the troubleshooting techniques, down to the system call tracing, and
I'm only left with more questions than answers.

My NT box is running SP4.  Perhaps that's the problem?  Has anyone had
any experience using NT4-SP4 as a client to a Linux Samba server?

A tantot.
quality costs *less*

More information about the samba mailing list