request_oplock_break - Samba 2.0.0

Gregory Hosler gregory.hosler at
Sat Jan 16 05:10:45 GMT 1999

I am having a very consistent, extremely reproduceable (to the point that
I canot figure how to get around it) occurance of the request_oplock_break

I started to see this in 1.9.18p10, and upgraded to 2.0.0. The problem
still persists. I have searched thru the samba listproc archives, but
have not found anything that seems applicable.

My samba server is running on Solaris 2.5.1

My client is NT4 sp3

I have a share (it happens to be the root share of the smb server).

I mount the network drive, and click on it, and NT4 will hang for quite
a while. Seems like forever, but it is probably only 1 or 2 minutes.
When it comes back, the directory listing is only partially listed.
a refresh will come back w/ a similiar (i.e. partial) listing another
couple of minutes later. I think I have seen different sets of partial
listings, if it matters.

After two or three of these attempts I will start to see the following 
message in my client smb log file:

[1999/01/16 12:19:29, 0] smbd/oplock.c:(943)
  request_oplock_break: no response received to oplock break
  request to pid 4192 on port 33425 for dev = 28c0004, inode = 28752

pid 4192 is:

    ps -ef | grep 4192
    greg  4192   131  0 11:43:07 ?        0:00 smbd

("greg" is the network user trying to access the share).

I have tried a 2nd PC, and the problem also occurs there, ruling out
the network card (whish due to other testing, was not high on the list
of suspects.)

This is entirely, 100% reproduceable. I have tried rebooting NT, solaris,
to no avail. I am at my wits end. I looked at the code, but it is not
clear to me how to continue diagnosing / debugging this.

I am looking for suggestions as to how best to proceed. (solutions also
welcome, though from my listproc searchs, I was unable to locate any :(

as an aside, I put the following in my [global] sections of the smb.conf
and I am not seeing the verbosity I would expect.

           debug level = 10

I see some debug levels, but for example, oplock.c should be logging
alot more when it is at debug level 10, and I am not seeing this.

If my smb.conf is relavant to this discussion, or more of my logfile,
I will be happy to post, but wanted to conserve teh bandwidth on this 
first post.

thanks, and rgds,


E-Mail: Gregory Hosler <gregory.hosler at>
Date: 16-Jan-99
Time: 12:22:519

"And where were you at 00:00:00 GMT, January 1, 1970?"

As far as the laws of mathematics refer to reality, they are not
certain, and as far as they are certain, they do not refer to reality.
                -- Albert Einstein

More information about the samba mailing list