Building Samba 2.0.0 on Redhat 5.2

Jim Morris Jim at
Fri Jan 15 22:05:21 GMT 1999

Hi all.

I am having trouble installing Samba 2.0.0 (from the .tar.gz file) on a
Redhat 5.2 system, running Linux 2.0.36.  I am *NOT* using shadow
passwords, but of course am using PAM, since that is the default under
Redhat.  Any attempt to access the Samba server using smbclient or any
other client results in a "bad username/password" type error message
(for valid user/password pairs).  I've tried encrypted and unencrypted
password operation too.  For now, I've reverted to my 1.9.18p10
binaries, which work fine with the same smb.conf.

Basically, it appears that using the new configure script, something is
getting setup wrong as far as password authentication goes.  No matter
what options I try to pass to comfigure, it appears that it is setting
up for both PAM and shadow password authentication (it finds a shadow.h
I believe).  The only other time I have personally since this error crop
up is when I installed Samba once on a system that DID use shadow
passwords, and I had built it without shadow password support. 
Compiling for shadow support in that case fixed the problem.

Has anyone else been able to build and successfully USE Samba 2.0.0 on a
Redhat 5.x system? If so, did you have to do anything unusual when
running configure?

I've tried and tried, and I guess I'm an old dog that can't learn new
tricks or something... I never had trouble picking the options I needed
when editing the old makefile, but configure isn't just making the right
decisions for me.  I've used Samba since 1994, and never had trouble
building a working copy until now!  Guess I should have tried 2.0.0
before it was released, so this could have been reported...

| Jim Morris  | Business:  jmorris at |
|             | Personal:  Jim at        |
|    World Wide Web:      |

More information about the samba mailing list