Authentication failing

Thomas Wagner wagner at
Fri Jan 8 21:47:32 GMT 1999

I'm running version 2.0 beta. During the initial installation, I configured Samba to authenticate with an NT server. It worked as expected. Now, I want to reconfigure Samba with security = user.  I've set encryption = no (and insured that the NT client is sending plain text passwords), and I've removed the references in the smb.conf file to PASSWORD SERVER =.

As I expected, the NT workstation client produced a dialog box prompting for the username and password. However, when the ENTER key is pressed, the NT workstation comes back with another dialog box, re-prompting for the name/password. 

In the log."user" file, I get the following:

[1999/01/08 11:59:58, 3] smbd/process.c:switch_message(402)
  switch message SMBsesssetupX (pid 2709)
[1999/01/08 11:59:58, 3] smbd/reply.c:reply_sesssetup_and_X(675)
  Domain=[MSCC]  NativeOS=[Windows NT 1381] NativeLanMan=[]
[1999/01/08 11:59:58, 3] smbd/reply.c:reply_sesssetup_and_X(679)
[1999/01/08 11:59:58, 4] passdb/pass_check.c:pass_check(791)
  Checking password for user wagner (l=5)
[1999/01/08 11:59:58, 3] smbd/error.c:error_packet(138)
  error packet at line 781 cmd=115 (SMBsesssetupX) eclass=2 ecode=2
[1999/01/08 11:59:58, 3] smbd/error.c:error_packet(143)
  error string = No such file or directory

What is going on???? There was also a reference to "No  entry for user wagner in protected database!"
What file(s) is Samba trying to read (and can't)????
When  I ran smbpasswd -j DOM -r DOMPDC, did that do something that now needs to be undone?

-------------- next part --------------
HTML attachment scrubbed and removed

More information about the samba mailing list