samba 2.0.2: problems mounting one filesystem from one PC

Jim Graham graham at
Fri Feb 26 20:57:34 GMT 1999

If I've missed something obvious here, I'll gladly take RTFM as an
answer...just please tell me which FM, and what I'm looking for.  :-)

My users here access several network drives via Samba from their PCs
(a mix of Windows 95/98 and NT).  All of the PCs have had the patches
for authentication applied (i.e., the two now included in the Samba
distribution).  I'm having trouble, though, with *ONE* user's PC, and
then only with *ONE* filesystem.  :-(

She is able to mount the so-called 'h' drive (a relic from long ago
that is now mostly a common junk area), which everyone accesses as a
guest account (i.e., no password).  She is able to mount her home
directory on the same machine (which, of course, requires her
username/password).  She is *NOT* able to access another filesystem
on that same machine (which also requires a password, btw).

We've tried all sorts of ways to access it....  First, we started with
what it should, if I've understood correctly, be (and what works from
the 95/98 machines):


This results in an error from NT saying ``The network name cannot be
found''.  So, we tried the following just for grins:


and told NT to connect as her username/password.  This time, we got
an error saying:  ``incorrect password or unknown username for ....''
The username and password were very definitely correct for her on
that system.  And, just to test/prove that, we tried using a couple
of other users' username/password pairs, and it made no difference.

At first, I thought it was something strange about NT, as she's one of
only a couple of people running NT, and none of the 95/98 users have
reported any problems.  But, another NT user (same vendor, same hardware,
same software, same everything) has no problems with any/all of them.

Oh, one more thing....  My first thought was to look in the logs to
see what clues might be there.  Nope, nothing there.  Oh, sure, the
H-drive stuff, access to printers, home directories, etc., was all
there, but nothing for her machine attempting to hit this one ``drive''.

The drive itself is defined as:

   comment = The 'sdd-work' drive
   path = /documentation/jocaspocas/guidocs/sdd
   browseable = yes
   read only = no
   follow symlinks = no
   invalid users = root

and the global settings are:

   log level = 1
   time server = True
   workgroup = jocas
   printing = sysv
   printcap name = /usr/local/etc/samba_printcap
   load printers = yes
   guest account = nobody
   hosts allow = .....
   domain master = no
   local master = yes
   preferred master = yes
   os level = 65

The machine everything is trying to access is a SPARCcenter 2000E
running Solaris 2.5.1.  The same data is accessible from another
machine (NFS...long story), so we tried it, too, and got exactly
the same results.  That machine, btw, is an Enterprise 3500 running
Solaris 7 and Samba 1.9.18p3.

Does anyone have any idea what might be going on here?


73 DE N5IAL (/4)              graham at  ||  jim at

         No, I'm not going to explain it.  If you can't figure it
         out, you didn't want to know anyway...      --Larry Wall

More information about the samba mailing list