very confusing problem

Stephen L Arnold arnold.steve at
Tue Feb 23 18:23:20 GMT 1999

When the world was young, Volker Lendecke 
<Volker.Lendecke at SerNet.DE> carved some runes like this:  

> Hank Burton writes:
>  > ANY HELP / IDEAS would be greatly appreaciated.
> Sounds like a permission problem on the unix side. Did you set 'write ok =
> yes' in the share definition? Check the uid that's used on the unix side
> with smbstatus, and check the unix permissions against that.

Sorry, but I'm pretty sure the share settings (writable=yes, write 
list, valid users, etc) will have no effect whatsoever if the 
underlying directory permissions are set incorrectly.  For example, 
on the last samba box I set up, I could not (as a "normal" user) 
write any files to the public shares I created (writing to the home 
share of that user worked fine).  I tried all the relevant smb.conf 
options I could think of, but I always got "Access Denied" or 
"Permission Denied" errors trying to create/copy files to those 
shares.  It finally dawned on me (sometimes it takes a while, but 
eventually I get it ;-) to check the underlying permissions and 
sure enough, those dirs were owned by root/group root.  When I 
changed the permissions to a different group (and added the users 
to that group) everything worked fine.  Granted, most of you (I'm 
sure) are not as dumb as I am, but this is one of the more subtle 
aspects of samba that seems to come back again and again...


More information about the samba mailing list