windows nt -> samba server on unix: slow login

ravi narayan ravi at
Mon Feb 22 22:47:38 GMT 1999


i have a strange problem that i am unable to fix. hope someone can help!
i have samba 2.0.0 running on a unix box. here is the global section:

netbios name = MATISSE
workgroup = WORKGROUP
wins support = yes
domain master = yes
local master = yes
preferred master = yes
os level = 65
max log size = 2000

i have two other systems: a windows nt 4.0 workstation PC, and a
windows 98 PC. i have no NT domain. i modified the registry, as suggested
in the docs, on both systems, to permit plaintext passwords.

from both systems, i can now access the samba server. however, on the
NT workstation system, the login process takes forever. when i map the
network drive, it takes about 2-3 minutes after which i am prompted for
a password. once i enter the password it takes another 2-3 minutes for
the drive to be mounted. once it is mounted, it works well and there are
no further problems. on the windows 98 system, there is no such problem,
and the login process is blazingly fast!

i tried all debug levels for smbd/nmbd to see if i can understand what
might be causing the problem. i also tried to trace the server processes,
but in both cases i just see the server processes mostly waiting for
input (trace: blocking on read/poll).

the paths i am trying to map are home directories. here is the relevant
section from my smb.conf file:

comment = Home Directories
read only = no
browseable = yes
writable = yes

any thoughts/suggestions/pointers would be greatly appreciated.

	-- ravi

More information about the samba mailing list