accessing server that has no unix account (/home/user)

beef at CyberTouch.ORG beef at CyberTouch.ORG
Mon Feb 15 17:15:53 GMT 1999

Hello Fellow Samba  users,

I have asked this before but unfortunately, with no response. So I 
will try to ask again.

I have two Unix servers running Samba. One is called freedom and 
the other freedom2. 

What i am trying to do is, to make one server (freedom2) contain 
shares but, the box itself does NOT have the the window users as 
accounts on it. In other words if my login on a win98 box is gerry, 
there is NO /home/gerry.

The samba docs, in particular smb.conf, leads me to think that it 
(smb.conf) checks the security = server and if server = freedom, 
that the account of the windows users would be verified by 
checking the /etc/master.passwd file. But it seems it does not 
work that way. Upon further reading of the smb.conf doc, it 
suggests making the security = share. I have tried that and get the 
same result.Which is that upon opening network neighborhood, I 
can see the computer freedom2, can click and see the shares, but 
when clicking on any share that is NOT public = yes, am asked for 
password for the share in question.

I was able to access this share by putting the dir for the share in 
/etc/exports and using Samba' s services on Freedom (same share 
name). However this does not seem the right way.

If in a company setting you want a Samba server to contain many 
shares but you do NOT want users (windows) to have unix 
accounts on that machine, how is it possible to access the shares?

On freedom, I have put the following in the smb.conf for the share 
on Freedom2:

   comment = image collection on Freedom2
   path = /images
   public = no    
   valid users = @wheel, @staff
   writeable = yes
   printable = no

I put the above because of the inablilty to access the share on 
freedom2 as shown below:

        log file = /usr/local/samba/lib/log.%m
        wins proxy = yes
        max log size = 50  
        domain master = no
        dns proxy = no  
        password server = freedom
        preferred master = no
        password level = 8
        logon path = \\%L\Profiles\%U
        security = share (tried with securtiy = server; but no luck)
      comment = private collection of images
      public = no
      path = /data/pics
      valid users = @wheel

In the /etc/group file listed for wheel, has me and has a unix 
account of mine (different name). In addition as per the smb.conf 
document page, a file called was made with rw_ only to 
root, with the following entry:

g7 = lnb  with g7 being a valid account on freedom2 and mapping 
that name to lnb, a valid win98 user.

Where am i going wrong?

Thank you in advance for your help,

Lanny Baron

More information about the samba mailing list