Beware: Samba is a hoax

alex at alex at
Fri Feb 5 13:53:51 GMT 1999

I can only conclude that Samba is an elaborate hoax and here's why.

1) Setup is more complex than Sendmail (it set the standard for complexity)
2) Even the simplest smb.conf causes trouble
3) You can pass ALL the tests in the DIAGNOSIS procedure, AND

Samba will still not let you SHARE FILES or SHARE PRINTERS between Windows
and Unix

but you WILL be able to BROWSE YOUR SHARES (Just pretend it might be useful)

OK, I admit I'm annoyed.  I have been working for too long to get this
working with even the simplest smb.conf file and after I pass ALL the
diagnostic steps (yes I have gone through every one with flying colours)
here's what happens.

On a W95 system, in a DOS box I do Test #9

net use X: \\lewis\tmp

I'm asked for a password and get 'command completed successfully' So I have
passed the test right?  WRONG!  Here's what happens when I try and do
something with the new X: drive

I change to drive x: and get
then I type DIR 
(and yes I type a carriage return in case some nitpicker thinks I jest)

The result:  W95 full seizure after a partial listing (yes, only some) of
the files in /tmp

The ONLY solution I have found for this seizure is a full power off reboot.
(I have waited as long as a half hour to let W95 sort it all out. Perhaps
the 'W95 team' can let me know if that's long enough)

Same problem with Test #10

I try to 'browse the server' and the shares show up.  I passed the test right?
WRONG!  Try a click on one of those shared resources and I get another full
W95 system seizure and only pulling the plug will get me out of it.

What would your conclusion be?  There are no other troubleshooting tips

provided by the 'Samba Team'.  So I can browse but not share files (let
alone printers).  I tell you : SAMBA is a HOAX!  I have posted my trouble
on the local Linux user's groups but every 'solution' just shows that they
don't have it working right either.  Read the Samba digests - see any

If you got this far here's some info on my configuration:
Samba versions tried: 1.9.17, 1.9.18, 2.0.0
Linux running on Redhat Ver 5.0
Win95 clients with all the latest patches (including the password fix - I
can authenticate)

testparm provides NO ERRORS

my smb.conf (simple isn't it - hard to believe IT DOESN'T WORK)

# Samba config file created using SWAT
# from localhost (
# Date: 1999/02/04 23:21:08

# Global parameters
	workgroup = AVANTEL
	netbios name = LEWIS
	interfaces =
	log level = 2
	guest account = guest

	comment = Test
	path = /tmp

And in case you got this far and are willing to help - how about a test
procedure for going that extra step that lets me actually access shared
files and then some tips for when it doesn't work.

Unless of course, Samba really is a hoax!

More information about the samba mailing list