invalid parameter

Gerald Carter cartegw at Eng.Auburn.EDU
Wed Dec 8 00:09:51 GMT 1999

Kirk Reiser wrote:
> Hi Folks:  I just upgraded a samba server from 2.0.5a to 2.0.6 and all
> of a sudden I am getting invalid parameter errors on the windows-9x
> boes when they try to logon to the server.  Does anyone have any idea
> what might be going on?  Samba is running on a linux 2.2.12 box and
> connecting to 95 and 98 boxes.  It just stopped working when I
> upgraded.  I have tried commenting out domainlogon and the net logon
> share with no difference in result.  I also tried using a valid users
> line just for grins but also no affect.
> I certainly would appreciate any help or suggestions people might
> have.  It's been driving me crazy!


I'm **very** interested in this.  Can you send me 
more information?  Specifically things like 

 * what linux distribution you're running + any 
   upgrades you have made (e.g kernel, glib, etc...)

  * Your smb.conf

  * output from testparm

You can also get a packet dump from the Linux box

	tcpdump -w /tmp/output.raw -s 1500 host <windows hostname>

	(Or level 10 debug logs from smbd)

and send that to me as well?  There have been a couple of 
reports of this lately, but I cannot reproduce it.
Normally this error pops up when the netbios name and 
workgroup of the Samba box are the same.  However since you 
said it was working, I assume this is not the case here.

                            Gerald ( Jerry ) Carter	
Engineering Network Services                           Auburn University 
jerry at   

       "...a hundred billion castaways looking for a home."
                                  - Sting "Message in a Bottle" ( 1979 )

More information about the samba mailing list