Problem writing large files

Paulo Afonso Graner Fessel pafessel at
Tue Dec 7 16:40:27 GMT 1999

Kirk Patton wrote:
> Hello,
> I have recently run into a strage problem with Samba.
> I am running 2.0.6 on a linux 2.2.10 kernal, 450Mhz K6 box.
> The user is running a K6 NT 4.0 workstation.  Previously, she had been
> using a k5 based NT system.
> After she was upgraded the the faster system, she imeadiatly started
> having problems writing out large files to the samba shares.  Large
> being ~100k.

	Same problems here, regardless of oplocks being turned on or off. Besides,
the file being written remains locked as smbd enters a crazy "R" state. The
only way to kill the offending proccess and unlock the files is init 6.

> I tried to figure out what was going on by running a strace on the
> smbd child process.  As soon as I attached to the process, the file
> was able to complete its write operation.  If I monitored the smbd
> process before I tried to write the file, the problem would not
> manifest itself.  Otherwise, it would consistantly fail on large write
> operations.

	Hmmm, interesting. Could you describe more precisely exactly *how* the
write operation fails?

"The one that doesn't run the risk doesn't snap"

(Millôr, "Lições de Inglês Audiovisual", Pasquim nº117)

More information about the samba mailing list