File sharing problem with NT

Steve Litt slitt at
Mon Dec 6 15:33:51 GMT 1999

Next step is to have a guaranteed symptom reproduction of the simplest
possible nature. See if that one huge file, by itself, always produces the
symptom. Once you have a directory of files producing the symptom, mark all
files read only so you can run the test over and over. I'd look at three

1. tcpdump (using Samba.Org's version)
2. Log files
3. Exploit differences between successful and unsuccessful transfers.

Steve Litt

At 08:54 AM 12/06/1999 -0500, you wrote:
>On Fri, 03 Dec 1999, Steve Litt wrote:
>> What happens when you try to FTP the files? The root cause you
>> seek could possibly be outside of Samba.
>FTP works just fine. I regularly FTP over 250MB development
>environments (which is why I want to use Samba and share the
>Any other ideas?
>At 07:31 AM 12/04/1999 +1100, John Rousseau wrote:
>>I'm new to Samba, but I have searched the FAQ, DIAGNOSIS.txt and the
>>group archives with no success.
>>I'm running Samba 2.0.6 on RedHat 6.1 (glibc 2.1.2, kernel 2.2.12)
>>and sharing an ext2 filesystem.
>>I'm mounting this filesystem from an Intel Windows NT Server box
>>running service pack 5.
>>When I start to copy files (MKS cp -r) from my NT box to my Linux
>>box, everything goes along fine for a while (~10-15 seconds) until
>>my copy hits a large file (the one that is failing at this point is
>>5.9MB). At that point the NT box says (after a few seconds) "An
>>unexpected network error occurred." (thanks for the help Bill!) and
>>the copy fails. Trying to look at the shared drive from the NT box
>>hangs, but after about a minute it recovers and looks fine.
>>There are no other clients hitting the server.
>>The machines are about 5 feet apart on the same piece of 100MB
>>ethernet. The Linux box is a 128MB PII-200. The NT box is a 256MB
>>I've tried pushing up "oplock break wait time" to 50 ms without
>>success. Running with "debug level = 2" doesn't show any error
>>messages on the Linux side in the log. I've tried running with "nt
>>smb support" both on and off without success.
>>If I try and copy a tree of small files, the copy succeeds.
>>Anybody have any suggestions? Is there a FAQ entry that I missed?
>>John Rousseau                               jrr at
>>SilverStream Software                                           
>>1 Burlington Woods                        Phone: +1 781 238 5564
>>Burlington, MA 01803                        Fax: +1 781 238 5499

More information about the samba mailing list