2.0.5a configure bug fcntl test on automounted source dir

Tom Schutter tom at platte.com
Mon Aug 23 16:36:15 GMT 1999


I believe that I have found a bug in the 2.0.5a configure process.  If
the source tarball is extracted to an automounted directory, and you
run configure, it will fail the fcntl_lock test, resulting in this
message at the end of the configure process:
  WARNING: No locking available. Running Samba would be unsafe

To verify that the automounted directory is the problem, I put an
"exit 1" in the configure script after the fcntl_lock conftest program
was compiled (~line 8558), but before it was run.  I then tried this
  if ( ./conftest ); then echo success; fi
which echoed nothing.  I then copied conftest to /tmp and tried the
above command again, which resulted in the echo of "success".  I then
extracted the tarball to /tmp, and configure ran fine.

If the directory is automounted from the local machine, there is no
problem.  I have reproduced the problem when it is automounted from a
Redhat Linux 6.0 box to a Solaris 2.5 box, as well as if it is
automounted from an OSF/1 box to a Solaris box.

I have reproduced the problem with Solaris 2.5, SunOS 4.1.3, and OSF/1
4.0.  I have never seen this problem in any previous versions of
Samba, from 1.9.16 up to 2.0.2.  I have not been able to test 2.0.3 or
2.0.4, because I cannot seem to locate them on the ftp site, which
means that I am not sure if this bug was introduced in 2.0.3, 2.0.4,
or 2.0.5.

If there is any more information that I can provide, please ask.  I
have not stepped through conftest with a debugger, mainly because I
have never done so in a multithreaded app, which the fcntl conftest
executable is.

Tom Schutter (mailto:tom at platte.com)
Platte River Associates, Inc. (http://www.platte.com)

More information about the samba mailing list