Help needed using Samba over SSH (DOS works, Win9x doesn't)

Rob Ginn rob at
Fri Aug 13 17:57:27 GMT 1999

Hi all,
I've been trying to mount partitions on a UNIX machine behind a
firewall on a Windows machine.  This works fine inside the firewall,
but from outside I need to tunnel through it using SSH.  I can
get this to work from a DOS window on the Windows machine by
forwarding port 139, but when I try to access a file from the
GUI, I get a "bad directory" error on windows.  An unsatisfactory
workaround is to drag the file from the SAMBA server to the local
desktop, work oon it, and then drag it back to the SAMBA server.

I've tried multiple UNIXes, 2 versions of SSH on UNIX, and 2 versions
of SSH on Windows.  I also tried both Win95 and Win98.  I thought maybe
there were some UDP packets necessary from the GUI side, but when
I used TCP dump on an unencrypted connection (which worked), I didn't
see any.  I also tried running SSH inside the firewall which "probably"
let any UDP packets through direct (the docs on windows SSH programs
didn't really address what happens to the corresponding UDP port when
you forward a TCP port).  
I searched the Usenet (where there are a number of requests on how to
do thus but no answers -- plus they don't even have it working with DOS).
And I searched the archives of this list -- where I see that someone
described the same symptoms back in 1997, but no solution was discussed.

So, does anyone know how to do this now?  If not, does anyone know why
it's not working (i.e. what exactly is the problem -- so I can figure
out a work around)?  Or, worst case, does anyone know what the specific
requests (packets sent) made by DOS programs vs the ones made by Win9x

Thanks in advance,
Rob Ginn

- Rob Ginn
rob at

More information about the samba mailing list