NULL filled corrupt files

ai Aichmair Christian schneck IMCEAMS-KEBALINZ_CENTRAL_ai at
Fri Aug 6 17:16:05 GMT 1999

Hi ! 
In SAMBA Digest 2189 , Gregor Longariva <grlongar at> wrote

> ------------------------------
> Date:   Mon, 2 Aug 1999 11:40:53 +0200
> From:   Gregor Longariva <grlongar at>
> To:     samba at
> Subject: NULL filled corrupt files
> Message-ID: <19990802114053.B16854 at>
> Mime-Version: 1.0
> Content-Type: text/plain; charset=us-ascii
> Hello!
> I've seen, some people experienced this problem earlyer, but I have
> not found any solution in the mailing lists...
> So the problem is, copying files from an NT Workstation (SP5 ) 
> on a Samba server running under Linux (2.0.10) in some (rare) cases
> results in files exactly of the right size but filled with NULL bytes.
> I'm using samba 2.0.5a and likely since version 2.0.0 this problem
> occours.
> This is a very ugly situation since we cannot trust on storing file
> on our fileserver. Maybe some other people have still the same 
> problem and know, how I can fix it.
> I've done a search over all the documentation and mailing lists I
> know about Samba but I've found only people with the same problem -
> but no solution.
> The track down of the problem was done by somebody else earlyer on
> a Solaris machine.
> Maybe anybody knows what's the solution...?
> -- 
> Greetings
> Gregor Longariva
> <longariva at>

To me, it seems that this is the same Promlem as I already reported some
time ago I had with an older samba version which was not solved so far,
seems we have to warm this up.

here is my old mail (PR#11563)):
> Hi !
> I am running samba 1.9.18p10 on a HP-UX 9000/J210XC under HP-UX 10.20,
> attached you find the output from testparm smb.conf (aha.param).
> Now, by accident, I discovered a VERY strange symptom when the filesystems
gets full :
> Assume I have a FS with a size of 115Mb, and only 8  1k-blocks free ( 0%
minfree FS-parameter,
> "bdf -i" shows 8Kb free) and I want to copy a file
> from an NT-box ( NT4.0, SP3) to a subdirectory in this filesystem (the
> whole filesystem is shared, the UX-mountpoint is the share-point).
> Now, when copying a file ( C:\win\system\drivers\tape.sys, 16432 bytes)
> to this share-point,  the file-copy WORKS from the view of NT, i.e.  no
error, return-code is 0, etc. !
> The filesize on the server shows up as having 16432 bytes, (although
> this could never happen !), and the file has ONLY a few NULLs in it.
> If I repeat this ( the filesystem is FULL now !), I still get no error
> on the NT-box ( UX says "FS full ...", but instead the desired file is
> created on the server with a size of 0 bytes !
> I have already increased the debug-level to 10,  see the attached Logfile
"log.leros"  !
> The interesting thing here is that smbd seems to detect the problem ( no
> space message in logfiles ...), but doesn't remove the file after creating
the Dir-entry.
> WfW3.11 Clients DONT have this symptom !
> Although very insteresting is the fact, that this may happen EVEN
> EARLIER on JFS-Filesystem (HP-UX OnlineJFS)if there are not enough large
extends in the FS.
> The  problem happens BOTH on HPs std. FS (hfs) as well as on
> JFS-Filesystems, but it's  (from my side of view) not a HP FS-problem,
> as UX cp,  NT-boxes using NFS or ftp dont show this problem (and so dont
> I already tried changing oplocks=false, max disk size, etc., no result.
> I have already recompiled samba, tried various compile-options
> (-DQUOTAS, no FAST_SHARE_MODE, etc.) but nothing changed and could
> reproduce the same effect also on other (Linux, HP-UX 10.20, HP-UX 11.0)
systems too.

I fact, if this problem still exists, its very annoing, as with OnlineJFS
you can NEVER really trust a copy if 
the OnlineJFS doesnt have enough large extents even if there are lots of
small (1-8k) extents free ... !

I had the same problem with samba 2.0.2 too, is there anyone out there to
reproduce the problem ?

Thanks a lot in advance, 


More information about the samba mailing list