No locking avaliable - Compiling prblem

Branko Avramovski bramovsk at
Wed Aug 4 22:49:36 GMT 1999


I have a small network and a file and print server running on a 486 machine under Suse 6.0, kernel 2.0.36. Samba version is 1.9.18p10 that was precompiled and came with the Suse distribution pack, and it is working without any problem almost a year. Recently I have obtained a 2.0.5a source distribution and when I tried to compile the source I'm receiving the following message at the end of the ./configure script..

checking configure summary..
ERROR: No locking available.
Running samba would be unsafe
summary failure.
Aborting config.

Any suggestion??
I have also tried a binary version for Suse 6.0 and then I can not connect to the server (I've created new user acc. and passwd file and the smb.conf file is the same) after authentication passes (sorry I don't keep the original log file) but the log file record for each user that is trying to connect to the server contain a line similar to this and after that the server process is closed. 

can't change uid to...

Anyway I don't want to use binaries as I want to try some of the configuration options during compile process..


-------------- next part --------------
HTML attachment scrubbed and removed

More information about the samba mailing list