Installation Help, Please !!!

Sam WILLIAMS SGWilliams at
Wed Apr 28 19:16:21 GMT 1999

I have been having some difficulty with the installation of samba V2.0.3 on an ultraSparc 3000 server. I was able to get it built, I have configured, defined an smb.conf file, created an smbpasswd file, and I still get errors when I work through the Diagnosing Samba checklist. BTW, I have checked the conf file using testparms and corrected the problem mentioned there!  I am using the newest source release and building with gcc2.7.2.1.

There are really two issues at hand. The first is that even with nmbd running swat doesn't recognize its state. Looking at the source briefly, it appears that the determination is based on a connection test to I am assuming that this is failing and giving the bad status. I believe that the secondary problems are byproducts of the first,  however I am unfamiliar with the suite to the point that further diagnosis will be difficult. I really want to use the product, but I need to resolve this problem within the next couple of days if this is to happen. Unfortunately, if I fail it will be a black eye here for Open Source.  Please help...

When I run Test 7 as described in the diagnosing page from the server itself I get the following message:

# ./smbclient //case3000/mkslibs
Added interface ip= bcast= nmask=
Domain=[WORKGROUP] OS=[Unix] Server=[Samba 2.0.3]
tree connect failed: ERRSRV - ERRinvnetname (Invalid network name in tree connec

---------------------------------------------------------  My Smb.conf -----------------------------------
# cat ../lib/smb.conf
# Samba config file created using SWAT
# from (
# Date: 1999/04/28 13:54:39

# Global parameters
        netbios aliases = case
        interfaces =
        security = SHARE
        encrypt passwords = Yes
        null passwords = Yes
        passwd program = /usr/bin/passwd
        password level = 55
        username level = 5

        comment = Case_MKS
        path = /elec/mkslibs
        read only = No                                                         

Hopefully, someone can recommend a fix for me. Thanks for your help in advance.

Sam Williams
Sundstrand Aerospace

More information about the samba mailing list