Failed logins

Nicholas Tang ntang at
Mon Apr 26 17:49:41 GMT 1999

I've had several problems like this, and I posted about it earlier -
please, if anyone has any ideas, let me know.  If you need more info, let
me know.  I'm not sure what to give or how much detail to go into...

Here's our setup:

We have some people using NT boxes to access our SGI fileserver.  It's an
Origin 200, running IRIX 6.4, and Samba 2.0.3.  What will happen is
periodically, even though the user's password hasn't changed, they will be
unable to log into that machine - and be told that the username/password
combo is incorrect.  The SGI server is only serving files, no home
directories, no printers (we have separate NT servers for each of those
functions), and it is using "SERVER" level security.  Encryption is on.
Guest logins are disabled.

This has happened to 3 or 4 users over the past 6 weeks, and isn't
critical yet but could be at some point.  We've found that bringing them
to our NT PDC and having them change their password (even back to the same
one!) will fix the problem.

I'm confused greatly by this - one day, a user's login will work, another
day, it'll suddenly stop working.  One thing I noticed when it happened
the last time - the user was logged into his machine.  I logged in as
Administrator to install some software, and then logged in as myself to
make sure the software would load for a normal user.  Then I asked him to
log in - worked fine, the PDC authenticated him just fine... but when he
tried to use the samba-shared resources it told him he had the wrong
username and/or password.  It's like the Samba servers are caching
something and then forgetting about his account or something.  I don't
really know how it works that well or I might be able to figure it out.

While I'm at it, there are two other problems with our Samba server - it
is slow, browsing through the network neighborhood.  Where the NT servers'
windows pop up almost immediately if you double-click on their name in the
Network Neighborhood, the samba servers sometimes take 5 or 10 seconds
before the window pops up - I'm guessing the authentication is taking a
long time.

One other problem that we've noticed is that when connecting over our
shiva RAS the samba servers are accessible in their "root" shares, but if
you click two levels into them it says the folders don't exist.  This
works fine locally but not over the Shiva.

Anyway, if anyone has any ideas at all, please let me know.  I'm trying
hard to keep unix alive here, and so far I've been fighting a losing
battle.  I've only been here around 2 months, and I think I've already
managed to slow the wave of NT that's been sweeping across the company,
but at the rate it's going another year or two and there won't be any unix
servers left.  Things like this are not exactly convincing management that
unix servers are a good choice... especially since so many of the desktops
in here at NT workstation, not unix or linux workstations.  I'm hoping to
change that, but right now there's a feeling that NT is preferable to unix
in here no matter what the situation.  I like NT for some things but don't
want this place to go totally NT... 

Thanks in advance for any help anyone can extend.


Nicholas Tang     Senior System Administrator     R/GA Digital Studios
ntang at       (212) 946-4224 (voice)        (212) 946-4010 (fax)

More information about the samba mailing list