SMBFS in 2.2.x

Michael H. Warfield mhw at
Mon Apr 19 16:18:53 GMT 1999

Paul Sherwin enscribed thusly:
> At 07:11 19/04/99 +1000, you wrote:

> >Date: Sun, 18 Apr 1999 15:46:55 +1000
> >From: "Dean \"ZoRt!\" Hamstead" <zort at>
> >To: samba at
> >Subject: SMBFS in 2.2.x

> >Im wondering if anyone is getting the same problem with smbfs as i am
> >with the 2.2.x kernels

> >when i try to smbmount a share i get the following on the screen
> >"SMBFS: need mount version 6"

> >and also on the telnet shell or actual shell
> >"mount error: Invalid argument
> >Please look at smbmount's manual page...."

> >the mans have nothing

> >i revert back to 2.0.x and it werks fine

> Yes, this is a complete pain in the bum and had me fooled for a time. smbfs
> has been completely redesigned in 2.2 kernels to work with a new version of
> smbmount. The idea is to reduce dependence on kernel code so all those rich
> people with AIX, Solaris etc. can use smbmount as well. For some obscure
> reason the command syntax has changed. A mount is now something like

	Hmmm...  Considering that I'm currently maintaining the smbmount
program for the Samba team, the remark about people with AIX and Solaris
using smbmount is very interesting, since it's news to me.  AFAIK, there
are no plans afoot to port smbfs or smbmount to AIX or Solaris.  There is
smbsh (sometimes referred to as smbwrappers) which runs on a variety of
platforms and, in some cases, is a better solution than smbfs for individual

	The reason for the redesign was the realization that the old smbfs
lacked several critical features such as connection redirect and some
advanced protocol negotiation.  The new smbmount program creates a reconnect
daemon to manage the connection in the event of a session disconnect.

	The reason the syntax changed was that Volker based the new smbmount
on the smbclient program in Samba.  He then got distracted by little details
like his degree program and didn't have time to do anything about the
syntax problem or the race conditions or the autofs problems.  I've solved
the problems with autofs and with a variety of race conditions.  Fixing
the syntax problems with some sort of compatibility mode is rather high
on my todo list.  There also seem to be some lingering problems with
the reconnection process that I have not isolated down yet.

>     smbmount //server/sharename -c "mount /mnt/smbdir"

> You need to use the version of smbmount that comes with Samba 2.0. Of
> course, this won't work with V2.0 kernels... There are a few shell scripts
> floating around which attempt to do parameter translation depending on
> kernel version, but none of the ones I've tried actually work.

	I have one on my server at <>.
It has been recently revised to be a little more flexible and to eliminate
some code that was there to prevent autofs from hanging.  I was able to
determine that it was the SMBFS_DEBUG code in smbmount that was causing the
autofs automounter to hang and that disabling that option avoids the hang.
In particular, with the latest changes, prompts and console displays for
interactive use now work once again.  Anyone who is using a version prior
to the 0.5 version should update.

	If there is something that is not being translated right in my
script, I would like to know about it promptly.  If you have particulars,
please send me the details.

> Best regards, Paul

> Paul Sherwin Consulting    22 Monmouth Road, Oxford OX1 4TD, UK
> Phone +44 (0)1865 721438  
> Fax   +44 (0)1865 434331   mailto:psherwin at
> Pager +44 (0)7666 797228   

 Michael H. Warfield    |  (770) 985-6132   |  mhw at
  (The Mad Wizard)      |  (770) 925-8248   |
  NIC whois:  MHW9      |  An optimist believes we live in the best of all
 PGP Key: 0xDF1DD471    |  possible worlds.  A pessimist is sure of it!

More information about the samba mailing list