Samba: smbpasswd problem

Tse, Sam TseS at
Mon Apr 19 04:13:59 GMT 1999


I just start using Samba. I've installed Samba 2.0.2 on DG/UX. The file
service is working fine. However, I've problem to synchronise the SMB and
Unix passwords.

I generated the smbpasswd file by using command
     # cat /etc/passwd | >/opt/samba/private/smbpasswd

I've changed the permissions of smbpasswd and smb.conf to allow a normal
user to change passwords.

Then I log on as a normal user and run smbpasswd. After I put in old and new
passwords, I received the following error

	$ smbpasswd
	Old SMB password:
	New SMB password:
	Retype new SMB password:
	machine rejected the password change: Error was : The
specified password is invalid.
	Failed to change password for test

I check the /opt/samba/var/log.unxdg file, the following error appears

	[1999/04/19 14:02:10, 0] smbd/chgpasswd.c:check_oem_password(698)
	  check_oem_password: incorrect password length (-2092617017).

I've tried different passwords with different combinations and lengths. The
same error happens. 

Here is my smb.conf for your reference:

	   status = yes
	   netbios name = unxdg
	   security = server
	   password server = dc1
	   encrypt passwords = yes
	   server string =  unxdg (%v,%h)
	   load printers = no
	   log level = 1
	   log file = /opt/samba/var/log.%m
	   message command = csh -c '/usr/bin/X11/xedit -display :0 %s;rm
%s' &
	   read prediction = yes
	   socket options = TCP_NODELAY
	   valid chars = \366:\326 \345:\305 \344:\304
	   share modes = yes
	   locking = yes
	   strict locking = yes
	   keepalive = 30
	   guest account = guest
	   domain master = no
	   local master = no
	   unix password sync = true
	   passwd program = /sbin/passwd %u
	   passwd chat = *password* %o\n *password* %n\n *password* %n\n .
	   passwd chat debug = true

Any suggestion will be highly appreciated.


More information about the samba mailing list